NewYour coding agent can read the release notes before it upgrades.Set up the MCP server →
crates.io · #3202 most downloaded on crates.io
Rust implementation to parse and write DNS packets
Last release 2 months ago
26 Jul 2026
Ships fairly regularly
a new release about every 2 months
Nearly every release is documented
notes for 36 of 37 stable releases
1 version withdrawn
withdrawn after publishing
5 years old
38 releases · first in 2021
One column per quarter.
Document panic behaviour in header_buffer and change the functions to have a safe and _unchecked version.
Updated bitflags dependency to 2.11.
update version and changelog
update version and changelog
update version and changelog
update version and changelog
update version and changelog
update version and changelog
update change log and simple-dns version
update change log and simple-dns version
Changes internal implementation to use a Buffer struct instead of a byte slice
update changelog and simple-dns version
update changelog and simple-dns version
Fix panic when parsing (PR #40)
Allow labels starting with numbers (RFC-1123)
Correct serialization of OPT resource record for eDNS packets
new_with_labels to Name implementationLabel typeName::new.Remove the length octet from CAA value serialization
### Added - Add set_id function to packet
set_id function to packetAsync SimpleMdnsResponder::new_with_scope expects an optional future for graceful shutdown.
SimpleMdnsResponder::new_with_scope expects an optional future for graceful shutdown.Add NAPTR record type parsing (RFC 3403)
Fixes invalid name lengths when generating uncompressed bytes from a packet that was parsed from compressed data.
Fixes invalid rdata length when generating compressed packets.
TryFrom<'str> for TXT generating invalid CharacterStrings
Name::is_subdomain_of no longer return true for the same domainName::without to extract subdomains from a domainName compression now considers the full domain when creating pointers.
Add derived traits to PacketFlag that where removed by the previous version
### Added - Support to parse CAA records
write_to and write_compressed_to functions to Packet
write_to and write_compressed_to functions to PacketAdd DeRef and DerefMut implemetations for the ResourceRecord wrapper macro
Prevent panic! when trying to parse an empty slice
Fixes parsing for Name, CharacterString and SOA types
Add NOTIFY code (RFC 1995 and 1996)
thiserror dependencyInsufficientData for stream parsingAdd cache flush bit parsing to resource records
- Fix TXT records length
-Fix PTR parsing with compression
-Fix PTR parsing with compression
- Improve error handling
Fix Name compression when using multiple pointers
Fix a panic when parsing TXT records of length 0
Change internal data references to use Cow
Fix TXT Resource Record implementation
- Fix Name hash function - Fix SRV compression
Change DnsPacketContent visibility to pub(crate)
Nothing published for this version
Initial project release
Initial project release
Your coding agent can read these notes before it upgrades. Set up the MCP server →