NewYour coding agent can read the release notes before it upgrades.Set up the MCP server →
Packagist · #4551 most downloaded on Packagist
PHP HTTP Response Status code library
Last release 10 months ago
20 Nov 2025
Release timing varies
gaps range from 3 months to 2.8 years
Nearly every release is documented
notes for 13 of 13 stable releases
Nothing withdrawn
no release was ever pulled
10 years old
13 releases · first in 2016
composer(deps-dev): Bump phpstan/phpstan-deprecation-rules from 2.0.1 to 2.0.3 by @dependabot [bot] in #205
Full Changelog: 2.4.0...2.5.0
One column per quarter.
For a full diff see [2.4.0...2.5.0][2.4.0...2.5.0].
composer(deps-dev): bump ergebnis/php-cs-fixer-config from 6.21.0 to 6.22.0 by @dependabot in #116
phpstan/phpstan instead of vimeo/psalm by @localheinz in #167Full Changelog: 2.3.0...2.4.0
For a full diff see [2.3.0...2.4.0][2.3.0...2.4.0].
github-actions(deps): bump shivammathur/setup-php from 2.27.1 to 2.28.0 by @dependabot in #92
ergebnis/composer-normalize by @localheinz in #115Full Changelog: 2.2.0...2.3.0
For a full diff see [2.2.0...2.3.0][2.2.0...2.3.0].
docs: fix header link for 2.1.0 by @owenvoke in #67
Full Changelog: 2.1.0...2.2.0
For a full diff see [2.1.0...2.2.0][2.1.0...2.2.0].
Fix: Drop support for PHP 5.4 by @localheinz in #57
friendsofphp/php-cs-fixer by @localheinz in #65vimeo/psalm by @localheinz in #66Full Changelog: 2.0.1...2.1.0
For a full diff see [2.0.1...2.1.0][2.0.1...2.1.0].
github-actions(deps): bump actions/cache from 3.0.8 to 3.0.11 by @dependabot in #31
Full Changelog: 2.0.0...2.0.1
For a full diff see [2.0.0...2.0.1][2.0.0...2.0.1].
Vendor\Symfony::HTTP_UPGRADE_REQUIRED to undefined constant RFC\RFC2817::UPDATE_REQUIRED ([#56]), by [@jtheuerkauf]Fix: Remove deprecated constants by @localheinz in #26
CHANGELOG.md by @localheinz in #25Full Changelog: v1.1.2...2.0.0
For a full diff see [v1.1.2...2.0.0][v1.1.2...2.0.0].
CHANGELOG.md ([#25]), by [@localheinz]Teapot\StatusCode\RFC\RFC7231::NON_AUTHORATIVE_INFORMATION and Teapot\StatusCode\RFC\RFC2616::NON_AUTHORATIVE_INFORMATION ([#26]), by [@localheinz]Enhancement: Normalize composer.json ( #3 ), by @localheinz
squizlabs/php_codesniffer (#11), by @localheinzcomposer.json (#13), by @localheinzFor a full diff see [v1.1.0...v1.1.1][v1.1.0...v1.1.1].
For a full diff see [v1.1.0...v1.1.1][v1.1.0...v1.1.1].
For a full diff see [v1.0.2...v1.1.0][v1.0.2...v1.1.0].
For a full diff see [v1.0.2...v1.1.0][v1.0.2...v1.1.0].
For a full diff see [v1.0.1...v1.0.2][v1.0.1...v1.0.2].
For a full diff see [v1.0.1...v1.0.2][v1.0.1...v1.0.2].
For a full diff see [v1.0.0...v1.0.1][v1.0.0...v1.0.1].
For a full diff see [v1.0.0...v1.0.1][v1.0.0...v1.0.1].
For a full diff see [1091250...v1.0.0][1091250...v1.0.0].
For a full diff see 1091250...v1.0.0.
Your coding agent can read these notes before it upgrades. Set up the MCP server →