NewYour coding agent can read the release notes before it upgrades.Set up the MCP server →
Go modules · #3213 by repository stars
Last release 2 years ago
no release in 18 months
Release timing varies
gaps range from 9 days to 6 months
Nearly every release is documented
notes for 33 of 33 stable releases
Nothing withdrawn
no release was ever pulled
5 years old
78 releases · first in 2021
One column per quarter.
Avoid waiting containers block stateful pods' deletion.
Forbid flooing for unicast dst mac address in vxlan network.
Fix CVE-2016-2183 vulnerability of wehook component.
Fix nil pointer error which might happen in daemon during initializiation.
Add created host interface into CNI result for chained plugins like bandwidth.
Allow Pod names to be over 63 characters length.
Skip local vtep when generate vxlan fdb entry.
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Support multiple bgp peers for bgp network.
pkg/client to release tag.Fix ipv6 subnet capacity calculation error because of int64 overflow.
accept_ra sysctl before enable ipv6.forwarding. (#367 )Switch package ioutil to os because of deprecation
0.X.X.X subnets (#348 )Terminating if their owner referrence is removed (#353 )ioutil to os because of deprecation (#349 )Fix issue of manager getting stuck in processing subnet which starts with IP like 0.X.X.X
Introduce typha for large scale
Support modifying ipv6 route GC sysctl parameters by daemon
Remove all the onlink route flag usages to avoid ipv6 kernel bugs
onlink route flag usages to avoid ipv6 kernel bugsFix the error that underlay ip-retained pods will keep being Pending after they are deleted and recreated, if the underlay addresses run out
Fix daemon bug to allow to create dualstack pod with different v4/v6 vlan id
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Support global service when MultiCluster feature is enabled
onlink flag of the default route in pods to adapt to KatafailurePolicy of hybridnet pod mutating/validating webhook configuration to Ignore, to reduce the risk caused by hybridnet webhook169.254.1.1 on host if it's unreachable, to make sure proxy_arp can workNothing published for this version
Remove DualStack feature gate and make it built in
Fix address duplication error while active-standby switch of manager pods happens
Change IPInstance APIs and optimize IP allocation performance of manager
Fix the error that nodes get "empty" quota while the Underlay Network still have available addresses to allocate
Fix the error that deprecated bgp rules and routes are not cleaned
enable-vlan-arp-enhancement for daemon to enable/disable enhanced addressesDEFAULT_IP_FAMILY environment variable on dual-stack modevtep-address-cidrs flag for daemon to help select vtep addressFix creating ip-retained sts pod error when it is recreated and rescheduled to another node
Adjust client QPS and Burst configuration of manager
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Your coding agent can read these notes before it upgrades. Set up the MCP server →