NewYour coding agent can read the release notes before it upgrades.Set up the MCP server →
Go modules · #1263 by repository stars
Last release 6 years ago
no release in 18 months
Ships fairly regularly
a new release about every 3 weeks
Most releases are documented
notes for 16 of 18 stable releases
Nothing withdrawn
no release was ever pulled
8 years old
54 releases · first in 2019
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
One column per quarter.
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
This version fixes the provisioning failures caused by docker-ce-cli version mismatch. The older releases are not working anymore
docker-ce-cli version mismatch. The older releases are not working anymore (#907)machine-controller must be updated to v1.11.3 on existing clusters or otherwise newly created worker nodes will not work properly. The machine-controller can be updated on one of the following ways:
kubeone upgrade -f with the exact same config that's currently runningkubeone install with the exact same config that's currently runningmachine-controller and machine-controller-webhook deployments manuallydocker-ce-cli to the same version as docker-ce (#907)Add support for Kubernetes 1.18
leader_ip parsing from Terraform (#819)Nothing published for this version
Changelog since v0.10.0. For changelog since v0.11.0-beta.3, please check the [release notes]
Changelog since v0.10.0. For changelog since v0.11.0-beta.3, please check the release notes
aws-private configuration has been removedkubeone status command which checks the health of the cluster, API server and etcd (#734)cloud-config (#724).cloudProvider.Name is none (#696)kubeone reset failing to reset the cluster (#727)configure-cloud-routes bug for AWS causing kube-controller-manager to log warnings (#725)Nothing published for this version
Kubernetes 1.14 clusters are not supported as of this release because 1.14 isn't supported by the upstream anymore
Proxy settings defined in the config have precedence over those defined in Terraform
Nothing published for this version
Persist configured proxy in the system package managers
Nothing published for this version
The AWS Terraform configuration has been refactored a in backward-incompatible way
aws-private configuration has been removedkubeone status command which checks the health of the cluster, API server and etcd (#734)cloud-config (#724).cloudProvider.Name is none (#696)kubeone reset failing to reset the cluster (#727)configure-cloud-routes bug for AWS causing kube-controller-manager to log warnings (#725)Nothing published for this version
This should not introduce any breaking changes
go get to obtain KubeOne, you have to enable support for Go modules by setting the GO111MODULE environment variable to ongo get command: go get github.com/kubermatic/kubeone@v0.10.0kubectl scale is not working with kubectl v1.15 to due an upstream issue. Please upgrade to kubectl v1.16 if you want to use the kubectl scale command.cloud-config file from a YAML file (#623, #641)StaticAuditLog feature used to configure the audit log backend (#631)SystemPackages API field used to control configuration of repositories and packages (#670)OS_TENANT_ID environment variable (#551).workers.providerSpec.Labels field (#677).workers.providerSpec.Taints field (#678)rootDiskSizeGB field to the worker spec for OpenStack (#549)nodeVolumeAttachLimit field to the worker spec for OpenStack (#572)TrustDevicePath field to the worker spec for OpenStack (#686)BillingCycle and Tags fields to the worker spec for Packet (#686)isSpotInstance field (#686)ShortNames and AdditionalPrinterColumns for Cluster-API CRDs (#689)kubeone install and kubeone upgrade generating v1beta1 instead of v1beta2 kubeadm configuration file for 1.15 and 1.16 clusters (#670)DynamicAuditLog feature is enabled (#630)kubeone reset not retrying deleting worker nodes on error (#639)kubeone reset not skipping deleting worker nodes if the machine-controller CRDs are not deployed (#683)output.tf (#568)kubeone install failing if Terraform output is not provided (#574)machine-controller to v1.5.7 (#682)/etc/environment file (#687, #688)/etc/kubeone/proxy-env) generation (#650)machine-controller and machine-controller-webhook deployments not receiving the proxy configuration (#657)Update machine-controller to v1.5.3
machine-controller to v1.5.3 (#633)Fix cluster provisioning failures when DynamicAuditLog feature is enabled
Add ability to configure static networking for worker nodes
machine-controller to v1.5.1 (#602)This should not introduce any breaking change
go get to obtain KubeOne, you may have to enable support for Go modules by setting the GO111MODULE environment variable to onrootDiskSizeGB field to the worker spec for OpenStack (#549)nodeVolumeAttachLimit field to the worker spec for OpenStack (#572)OS_TENANT_ID environment variable (#551)Fix the CNI plugin URL for cluster upgrades on CoreOS
Fix .ClusterNetwork.PodSubnet not being respected when using the Weave-Net CNI plugin
.ClusterNetwork.PodSubnet not being respected when using the Weave-Net CNI plugin (#540)kubeadm preflight check failure (IsDockerSystemdCheck) on Ubuntu and CoreOS by making Docker use systemd cgroups driver (#536, #541)kubeadm preflight check failure on CentOS due to kubelet service not being enabled (#541)Nothing published for this version
The Terraform integration now requires Terraform v0.12+
terraform output generated with Terraform
v0.11 or older anymoreoutput.tf) has been changed and KubeOne is not able
to parse the old template anymore. You can check the output template
used by example Terraform scripts as a
referencekubeone completion command for generating the shell completion scripts for bash and zsh (#484)kubeone document command for generating man pages and KubeOne documentation (#484)kubeone reset failing if a MachineSet or Machine object has been already deleted and include more details in the error messages (#508)stdin) (#479)machine-controller to v1.3.0 (#499)kubelet on control plane nodes if proxy settings are provided (#496)## Added * Add support for VMware vSphere
Add WeaveNet as an additional CNI plugin
Nothing published for this version
Fix a missing JSON tag on the Name field, so specifying name in lowercase in the manifest works as expected
Provide the --kubelet-preferred-address-types flag to metrics-server, so it works on all providers
--kubelet-preferred-address-types flag to metrics-server, so it works on all providers (#424)Nothing published for this version
We're excited to announce that as of this release KubeOne is in beta! We have the new backwards compatibility policy going in effect as of this releas
We're excited to announce that as of this release KubeOne is in beta! We have the new backwards compatibility policy going in effect as of this release.
Check out the documentation for this release to find out how to get started with KubeOne.
config migrate command for migrating old configuration manifests to KubeOneCluster manifests (#408)config print command for printing an example KubeOneCluster manifest (#412, #415)metrics-server by default (#338, #351)ssh_username variable in the Terraform output (#350)-external-cloud-provider flag to machine-controller when external cloud provider is enabled (#361)machine-controller to v1.1.5 (#378)machine-controller if it's not deployed (#392)Add support for Kubernetes 1.14
Nothing published for this version
In #264 the environment variable names were changed to match names used by Terraform. In order for KubeOne to correctly fetch credentials you need to
DIGITALOCEAN_TOKEN instead of DO_TOKENOS_USERNAME instead of OS_USER_NAMEHCLOUD_TOKEN instead of HZ_TOKENcloud-config file is now required for OpenStack clusters. Validation will fail if the cloud-config is not provided. See the OpenStack quickstart for details how the cloud-config file should look like.backups section from the existing configuration files. If you wish to deploy Ark on new clusters you have to do it manually.--destory-workers to true for the kubeone reset command (#252)cloud-config file for OpenStack is required (#253)If you're using provider.Name external to configure control plane nodes to work with external CCM you need to:
provider.Name external to configure control plane nodes to work with external CCM you need to:
provider.Name to name of the cloud provider you're using or to none (see config.yaml.dist for supported values),provider.External to true.provider.Name none:
machine-controller you need to set MachineController.Provider to name of the cloud provider you're using for worker nodes,MachineController.Deploy to false, so validation passes.kubeone version command (#221)none provider bugs and ensure correct behavior (#227)Provider.External to true instead of setting Provider.Name to external (#230, #237)machine-controller on uninitialized nodes (#241)Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Deploy machine-controller v1.0.4 instead of v0.10.0 to fix CVE-2019-5736
apt-get/yum and curl (#182)provider.Name to be specified for providers without external Cloud Controller Manager (#161)--verbose and --tfjson are global flagsgithub.com/kubermatic/kubeone)machine-controller v1.0.4 instead of v0.10.0 to fix CVE-2019-5736 (#191)Nothing published for this version
Nothing published for this version
Nothing published for this version
Your coding agent can read these notes before it upgrades. Set up the MCP server →