NewYour coding agent can read the release notes before it upgrades.Set up the MCP server →
Maven Central
Maven Central
Apache HttpComponents Client (OSGi bundle)
Last release 8 years ago
no release in 18 months
Ships fairly regularly
a new release about every 8 months
Unknown
no stable releases
Nothing withdrawn
no release was ever pulled
11 years old
5 releases · first in 2016
Drag across the ruler to compare, or tap a release to open it.
This BETA release resolves compatibility issues with Java 11 new TLS engine as well as a number of defects found since the previous release.
This BETA release resolves compatibility issues with Java 11 new TLS engine as well as a number of defects found since the previous release.
Notable new features in this release:
JDK 11 compatibility
Support for request specific push consumers
Support for Reactive Streams API [http://www.reactive-streams.org/]
This is the first BETA release of HttpClient 5.0. The 5.0 release serices introduces support for the HTTP/2 protocol and event driven messaging APIs c
This is the first BETA release of HttpClient 5.0. The 5.0 release serices introduces support for the HTTP/2 protocol and event driven messaging APIs consistent for all supported HTTP protocol versions.
Your coding agent can read these notes before it upgrades. Set up the MCP server →
This is a major release that introduces support for the HTTP/2 protocol and event driven messaging APIs consistent for all supported HTTP protocol ver
This is a major release that introduces support for the HTTP/2 protocol and event driven messaging APIs consistent for all supported HTTP protocol versions.
HttpClient ships with two client implementations:
HttpClient Classic is based on the classic (blocking) I/O model; largely compatible with the 4.x APIs; supports HTTP/1.1 only.
HttpClient Async is based on NIO model; new event driven APIs consistent for all supported HTTP protocol versions; supports both HTTP/1.1 and HTTP/2.
Notable new features in this release:
Asynchronous HttpClient implementations optimized for HTTP/2 multiplexed request execution.
Full support for HTTP caching by asynchronous HttpClient implementations including streaming message exchanages.
Notable changes and features included in the 5.0 series are:
Support for the HTTP/2 protocol and conformance to requirements and recommendations of the latest HTTP/2 protocol specification documents (RFC 7540, RFC 7541.)
Supported features:
** HPACK header compression ** Stream multiplexing (client and server) ** Flow control ** Response push ** Message trailers ** Expect-continue handshake ** Connection validation (ping) ** Application-layer protocol negotiation (ALPN) on Java 9.0.1+ ** TLS 1.2 security features
Improved conformance to requirements and recommendations of the latest HTTP/1.1 protocol specification documents (RFC 7230, RFC 7231.)
Redesigned connection pool implementation with reduced pool lock contention.
Package name space changed to 'org.apache.hc.client5'.
Maven group id changed to 'org.apache.httpcomponents.client5'.
Apache Log4j2 logging APIs used for internal logging instead of Commons Logging APIs.
HttpClient 5.0 releases can be co-located with earlier major versions on the same classpath due to the change in package names and Maven module coordinates.
Please note that as of 5.0, HttpClient requires Java 1.7 or newer.
This is a major release that introduces support for the HTTP/2 protocol and event driven messaging APIs consistent for all supported HTTP protocol ver
This is a major release that introduces support for the HTTP/2 protocol and event driven messaging APIs consistent for all supported HTTP protocol versions.
HttpClient ships with two client implementations:
HttpClient Classic is based on the classic (blocking) I/O model; largely compatible with the 4.x APIs; supports HTTP/1.1 only.
HttpClient Async is based on NIO model; new event driven APIs consistent for all supported HTTP protocol versions; supports both HTTP/1.1 and HTTP/2.
Notable changes and features included in the 5.0 series are:
Partial support for the HTTP/2 protocol and conformance to requirements and recommendations of the latest HTTP/2 protocol specification documents (RFC 7540, RFC 7541.)
Supported features:
** HPACK header compression ** Stream multiplexing (client and server) ** Flow control ** Response push ** Message trailers ** Expect-continue handshake ** Connection validation (ping) ** Application-layer protocol negotiation (ALPN) on Java 1.9+ ** TLS 1.2 security features
Improved conformance to requirements and recommendations of the latest HTTP/1.1 protocol specification documents (RFC 7230, RFC 7231.)
Redesigned connection pool implementation with reduced pool lock contention.
Package name space changed to 'org.apache.hc.client5'.
Maven group id changed to 'org.apache.httpcomponents.client5'.
Apache Log4j2 logging APIs used for internal logging instead of Commons Logging APIs.
Features that are presently NOT supported:
HTTP/2 transport (classic)
HTTP tunneling (async)
Automatic response content decompression (async)
Caching (async)
HttpClient 5.0 releases can be co-located with earlier major versions on the same classpath due to the change in package names and Maven module coordinates.
Please note that as of 5.0, HttpClient requires Java 1.7 or newer.
Please note that at this point 5.0 APIs are considered experimental and unstable and are expected to change in the coming releases without providing a migration path.
This major release renders HttpClient API incompatible with the stable 4.x branch and upgrades HTTP/1.1 protocol conformance to the requirements and r
This major release renders HttpClient API incompatible with the stable 4.x branch and upgrades HTTP/1.1 protocol conformance to the requirements and recommendations of the latest protocol specification. This release lays the foundation for transition to HTTP/2 as the primary transport protocol in the future releases.
Notable changes and features included in the 5.0 series are:
Improved conformance to requirements and recommendations of the latest HTTP/1.1 protocol specification (RFC 7230, RFC 7231, RFC 7235)
Package name space changed to 'org.apache.hc.client5'
Maven group id changed to 'org.apache.httpcomponents.client5'
By default the maximum connections per route limit is set to 5
By default connection request timeout and connect timeout are set to 3 minutes.
HttpClient 5.0 releases can be co-located with earlier versions, meaning you can have both 5.x and 4.x on the classpath without experiencing jar hell.
Please note that as of 5.0 HttpClient requires Java 1.7 or newer.
Please note that at this point we consider 5.0 APIs experimental and unstable and expect them to change in the coming releases without providing a migration path.
One column per quarter.