NewYour coding agent can read the release notes before it upgrades.Set up the MCP server →
NuGet · #741 most downloaded on NuGet
Javascript Object Signing and Encryption (JOSE), JSON Web Token (JWT), JSON Web Encryption (JWE) and JSON Web Key (JWK) Implementation for .NET Ultimate Javascript Object Signing and Encryption (JOSE), JSON Web Token (JWT), JSON Web Encryption (JWE) and JSON Web Key (JWK) Implementation for .NET and .NET Core. Minimallistic. Zero-dependency. Full suite of signature and encryption algorithms. Supports generating, decoding, encryption and compression of JSON Web Tokens. Full-blown support for JSON Web Keys (RFC 7517) and two way bridging with .NET core cryptography. JSON parsing agnostic. Supports two-phase validation. FIPS compliant. Unencoded payload and detached content support (RFC 7797). JSON Web Encryption (JWE, RFC 7516) support. Cross compatible with all major operating systems - Windows, Linux, MacOS and FreeBSD. Supported algorithms Signing: - HMAC signatures with HS256, HS384 and HS512. - ECDSA signatures with ES256, ES384 and ES512. - RSASSA-PKCS1-V1_5 signatures with RS256, RS384 and RS512. - RSASSA-PSS signatures (probabilistic signature scheme with appendix) with PS256, PS384 and PS512. - NONE (unprotected) plain text algorithm without integrity protection Encryption: - RSAES OAEP 256 384 512 encryption with A128CBC-HS256, A192CBC-HS384, A256CBC-HS512, A128GCM, A192GCM, A256GCM - RSAES OAEP encryption with A128CBC-HS256, A192CBC-HS384, A256CBC-HS512, A128GCM, A192GCM, A256GCM - RSAES-PKCS1-V1_5 encryption with A128CBC-HS256, A192CBC-HS384, A256CBC-HS512, A128GCM, A192GCM, A256GCM - Direct symmetric key encryption with pre-shared key A128CBC-HS256, A192CBC-HS384, A256CBC-HS512, A128GCM, A192GCM and A256GCM - A128KW, A192KW, A256KW encryption with A128CBC-HS256, A192CBC-HS384, A256CBC-HS512, A128GCM, A192GCM and A256GCM - A128GCMKW, A192GCMKW, A256GCMKW encryption with A128CBC-HS256, A192CBC-HS384, A256CBC-HS512, A128GCM, A192GCM and A256GCM - ECDH-ES encryption with A128CBC-HS256, A128GCM, A192GCM, A256GCM - ECDH-ES+A128KW, ECDH-ES+A192KW, ECDH-ES+A256KW encryption with A128CBC-HS256, A128GCM, A192GCM, A256GCM - PBES2-HS256+A128KW, PBES2-HS384+A192KW, PBES2-HS512+A256KW with A128CBC-HS256, A192CBC-HS384, A256CBC-HS512, A128GCM, A192GCM, A256GCM Compression: - DEFLATE compression RFC 7797: - Unencoded payload - Detached content RFC 7516: - JSON Web Encryption (JWE) support JSON Web Key (RFC 7517): - RSA, EC, oct keys - X509 Chains, SHA1 & SHA2 thumbprints
Last release 6 months ago
27 Mar 2026
Release timing varies
gaps range from 2 weeks to 1.3 years
Some releases are documented
notes for 10 of 34 stable releases
1 version withdrawn
withdrawn after publishing
127 years old
35 releases · first in 1900
Exteded public SDK for custom algorithms. Key utils for P1363 and DER ASN.1 encodings.
Exteded public SDK for custom algorithms. Key utils for P1363 and DER ASN.1 encodings.
Maintenance release, removed dependencies on external packages for .net6 and above.
Maintenance release, removed dependencies on external packages for .net6 and above.
One column per quarter.
Maintenance release, improved memory allocation for deflated tokens, bump up dependencies for netstandard2.1
Maintenance release, improved memory allocation for deflated tokens, bump up dependencies for netstandard2.1
Added new key management algorithms RSA-OAEP-384 and RSA-OAEP-512. Security fixes to prevent truncated AES GCM tag attacks.
Added new key management algorithms RSA-OAEP-384 and RSA-OAEP-512. Security fixes to prevent truncated AES GCM tag attacks.
Major upgrade introducing cross platform ECDH compatibility for P-384 and P-521 NIST Curves on Windows, Linux, Mac OS and FreeBSD. Bugfixes and more s
Major upgrade introducing cross platform ECDH compatibility for P-384 and P-521 NIST Curves on Windows, Linux, Mac OS and FreeBSD. Bugfixes and more security controls to address new threats.
Extra security controls
Extra security controls
Added additional security controls to allow customizing runtime library behavior and exclude outdated algorithms.
Bug fix release.
Bug fix release.
Json Web Keys (JWK) RFC 7517 support.
Json Web Keys (JWK) RFC 7517 support.
Switching to System.Text.Json for netstandard2.1
Switching to System.Text.Json for netstandard2.1
Bugfix release
Bugfix release
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Your coding agent can read these notes before it upgrades. Set up the MCP server →