NewYour coding agent can read the release notes before it upgrades.Set up the MCP server →
PyPI · #292 most downloaded on PyPI
Universal Command Line Environment for AWS.
Last release 1 months ago
27 Aug 2026
Ships fairly regularly
a new release about every 8 days
Nearly every release is documented
notes for 60 of the last 60 stable releases
Nothing withdrawn
no release was ever pulled
14 years old
2497 releases · first in 2012
bugfix:aws s3 cp: Fix issue with parts of a file being downloaded more than once when streaming to stdout (issue 1087 __)
bugfix:aws s3 cp: Fix issue with parts of a file being downloaded more than once when streaming to stdout (issue 1087)
bugfix:--no-sign-request: Fix issue where requests were still trying to be signed even though user used the --no-sign-request flag. (botocore issue 433)
bugfix:aws cloudsearchdomain search: Fix invalid signatures when using the aws cloudsearchdomain search command (issue 976)
feature:aws cloudhsm: Add support for AWS CloudHSM.
feature:aws cloudhsm: Add support for AWS CloudHSM.
feature:aws ecs: Add support for aws ecs, the Amazon EC2 Container Service (ECS)
feature:aws rds: Add Encryption at Rest and CloudHSM Support.
feature:aws ec2: Add Classic Link support
feature:aws cloudsearch: Update aws cloudsearch command to latest version
bugfix:aws cloudfront wait: Fix issue where wait commands did not stop waiting when a success state was reached. (botocore issue 426)
bugfix:aws ec2 run-instances: Allow binary files to be passed to --user-data (botocore issue 416)
bugfix:aws cloudsearchdomain suggest: Add --suggest-query option to fix the argument being shadowed by the top level --query option. (issue 1068)
bugfix:aws emr: Fix issue with endpoints for eu-central-1 and cn-north-1 (botocore issue 423)
bugfix:aws s3: Fix issue where empty XML nodes are now parsed as an empty string "" instead of null, which allows for round tripping aws s3 get/put-bucket-lifecycle (issue 1076)
One column per quarter.
bugfix:AssumeRole: Fix issue with cache filenames when assuming a role on Windows (issue 1063 __)
bugfix:AssumeRole: Fix issue with cache filenames when assuming a role on Windows (issue 1063)
bugfix:aws s3 ls: Fix issue when listing Amazon S3 objects containing non-ascii characters in eu-central-1 (issue 1046)
feature:aws storagegateway: Update the aws storagegateway command to the latest version
feature:aws emr: Update the aws emr command to the latest version
bugfix:aws emr create-cluster: Fix script runnner jar to the current region location when --enable-debugging is specified in the aws emr create-cluster command
bugfix:aws datapipeline get-pipeline-definition: Rename operation parameter --version to --pipeline-version to avoid shadowing a built in parameter (i
bugfix:aws datapipeline get-pipeline-definition: Rename operation parameter --version to --pipeline-version to avoid shadowing a built in parameter (issue 1058)
bugfix:pip installation: Fix issue where pip installations would cause an error due to the system's python configuration (issue 1051)
feature:aws elastictranscoder: Update the aws elastictranscoder command to the latest version
bugfix:Non-ascii chars: Fix issue where escape sequences were being printed instead of the non-ascii chars (issue 1048 __)
bugfix:Non-ascii chars: Fix issue where escape sequences were being printed instead of the non-ascii chars (issue 1048)
bugfix:aws iam create-virtual-mfa-device: Fix issue with --outfile not supporting relative paths (issue 1002)
feature:aws sqs: Add support for Amazon Simple Queue Service purge queue which allows users to delete the messages in their queue.
feature:aws sqs: Add support for Amazon Simple Queue Service purge queue which allows users to delete the messages in their queue.
feature:aws opsworks: Add AWS OpsWorks support for registering and assigning existing Amazon EC2 instances and on-premises servers.
feature:aws opsworks register: Registers an EC2 instance or machine with AWS OpsWorks. Registering a machine using this command will install the AWS OpsWorks agent on the target machine and register it with an existing OpsWorks stack.
bugfix:aws s3: Fix issue with expired signatures when retrying failed requests (botocore issue 399)
bugfix:aws cloudformation get-template: Fix error message when template does not exist (issue 1044)
feature:aws kinesis put-records: Add support for PutRecord operation. It writes multiple data records from a producer into an Amazon Kinesis stream in
feature:aws kinesis put-records: Add support for PutRecord operation. It writes multiple data records from a producer into an Amazon Kinesis stream in a single call
feature:aws iam get-account-authorization-details: Add support for GetAccountAuthorizationDetails operation. It retrieves information about all IAM users, groups, and roles in your account, including their relationships to one another and their attached policies.
feature:aws route53 update-hosted-zone-comment: Add support for updating the comment of a hosted zone.
bugfix:Timestamp Arguments: Fix issue where certain timestamps were not being accepted as valid input (botocore issue 389)
bugfix:aws s3: Skip files whose names cannot be properly decoded (issue 1038)
bugfix:aws kinesis put-record: Fix issue where --data argument was not being base64 encoded (issue 1033)
bugfix:aws cloudwatch put-metric-data: Fix issue where the values for --statistic-values were not being parsed properly (issue 1036)
feature:aws datapipeline: Add support for using AWS Data Pipeline templates to create pipelines and bind values to parameters in the pipeline
feature:aws datapipeline: Add support for using AWS Data Pipeline templates to create pipelines and bind values to parameters in the pipeline
feature:aws elastictranscoder: Add support for encryption of files in Amazon S3
bugfix:aws s3: Fix issue where requests were not being resigned correctly when using Signature Version 4 (botocore issue 388)
bugfix:aws s3: Fix issue where KMS encrypted objects could not be downloaded (issue 1026)
bugfix:aws s3: Fix issue where datetime's were not being parsed properly when a profile was specified (issue 1020 __)
bugfix:aws s3: Fix issue where datetime's were not being parsed properly when a profile was specified (issue 1020)
bugfix:Assume Role Credential Provider: Fix issue with parsing expiry time from assume role credential provider (botocore issue 387)
feature:aws redshift: Add support for integration with KMS
feature:aws redshift: Add support for integration with KMS
bugfix:aws cloudtrail create-subscription: Set a bucket config location constraint on buckets created outside of us-east-1. (issue 1013)
bugfix:aws deploy push: Fix s3 multipart uploads
bugfix:aws s3 ls: Fix return codes for non existing objects (issue 1008)
bugfix:Retrying Signed Requests: Fix issue where requests using Signature Version 4 signed with temporary credentials were not being retried properly, resulting in auth errors (botocore issue 379)
bugfix:aws s3api get-bucket-location: Fix issue where getting the bucket location for a bucket in eu-central-1 required specifying --region eu-central-1 (botocore issue 380)
bugfix:Timestamp Input: Fix regression where timestamps without any timezone information were not being handled properly (issue 982)
bugfix:Signature Version 4: You can enable Signature Version 4 for Amazon S3 commands by running aws configure set default.s3.signature_version s3v4 (issue 1006, botocore issue 382)
bugfix:aws emr: Fix issue where --ssh, --get, --put would not work when the cluster was in a waiting state (issue 1007)
feature:Binary File Input: Add support for reading file contents as binary by prepending the filename with fileb:// (issue 1010)
bugfix:Streaming Output File: Fix issue when streaming a response to a file and an error response is returned (issue 1012)
bugfix:Binary Output: Fix regression where binary output was no longer being base64 encoded (issue 1001, issue 970)
feature:aws s3: Add support for S3 notifications
feature:aws s3: Add support for S3 notifications
bugfix:aws configservice get-status: Fix connecting to endpoint without using ssl. (issue 998)
bugfix:aws deploy push: Fix some python compatibility issues (issue 1000)
feature:aws configservice: Adds support for AWS Config
feature:aws configservice: Adds support for AWS Config
feature:aws kms: Adds support AWS Key Management Service
feature:aws s3api: Adds support for S3 server-side encryption using KMS
feature:aws ec2: Adds support for EBS encryption using KMS
feature:aws cloudtrail: Adds support for CloudWatch Logs delivery
feature:aws cloudformation: Adds support for template summary.
feature:AssumeRole Credential Provider: Add support for assuming a role by configuring a role_arn and a source_profile in the AWS config file (issue 9
feature:AssumeRole Credential Provider: Add support for assuming a role by configuring a role_arn and a source_profile in the AWS config file (issue 991, issue 990)
feature:Waiters: Add a wait subcommand that allows for a command to block until an AWS resource reaches a given state (issue 992, issue 985)
bugfix:aws s3: Fix issue where request was not properly signed on retried requests for aws s3 (issue 986, botocore issue 375)
bugfix:aws s3: Fix issue where --exclude and --include were not being properly applied when a s3 prefix was provided. (issue 993)
feature:aws cloudfront: Adds support for wildcard cookie names and options caching.
feature:aws cloudfront: Adds support for wildcard cookie names and options caching.
feature:aws route53: Add further support for private dns and sigv4.
feature:aws cognito-sync: Add support for push sync.
bugfix:Pagination: Only display --page-size when an operation can be paginated (issue 956 __)
bugfix:Pagination: Only display --page-size when an operation can be paginated (issue 956)
feature:--generate-cli-skeleton: Generates a JSON skeleton to fill out and be used as input to --cli-input-json. (issue 963)
feature:--cli-input-json: Runs an operation using a global JSON file that supplies all of the operation's arguments. This JSON file can be generated by --generate-cli-skeleton. (issue 963)
feature:aws s3/s3api: Show hint about using the correct region when the corresponding error occurs (issue 968 __)
feature:aws s3/s3api: Show hint about using the correct region when the corresponding error occurs (issue 968)
feature:aws ec2 describe-volumes: Add support for optional pagination.
feature:aws ec2 describe-volumes: Add support for optional pagination.
feature:aws route53domains: Add support for auto-renew domains.
feature:aws cognito-identity: Add for Open-ID Connect.
feature:aws sts: Add support for Open-ID Connect
feature:aws iam: Add support for Open-ID Connect
bugfix:aws s3 sync: Fix issue when uploading with --exact-timestamps (issue 964)
bugfix:Retry: Fix issue where certain error codes were not being retried (botocore issue 361)
bugfix:aws emr ssh: Fix issue when using waiter interface to wait on the cluster state (issue 954)
feature:aws cloudsearch: Add support for advance Japanese language processing.
feature:aws cloudsearch: Add support for advance Japanese language processing.
feature:aws rds: Add support for gp2 which provides faster access than disk-based storage.
bugfix:aws s3 mv: Delete multi-part objects when transferring objects across regions using --source-region (issue 938)
bugfix:aws emr ssh: Fix issue with waiter configuration not being found (issue 937)
feature:aws dynamodb: Update aws dynamodb command to support storing and retrieving documents with full support for document models. New data types ar
feature:aws dynamodb: Update aws dynamodb command to support storing and retrieving documents with full support for document models. New data types are fully compatible with the JSON standard and allow you to nest document elements within one another.
bugfix:aws configure: Fix bug where aws configure was not properly writing out to the shared credentials file
bugfix:S3 Response Parsing: Fix regression for parsing S3 responses containing a status code of 200 with an error response body (botocore issue 342)
bugfix:Shorthand Error Message: Ensure the error message for shorthand parsing always contains the CLI argument name (issue 935)
bugfix:Response Parsing: Fix response parsing so that leading and trailing spaces are preserved
bugfix:Response Parsing: Fix response parsing so that leading and trailing spaces are preserved
feature:Shared Credentials File: The aws configure and aws configure set command now write out all credential variables to the shared credentials file ~/.aws/credentials (issue 847)
bugfix:aws s3: Write warnings and errors to standard error as opposed to standard output. (issue 919)
feature:aws s3: Add --only-show-errors option that displays errors and warnings but suppresses all other output.
feature:aws s3 cp: Added ability to upload local file streams from standard input to s3 and download s3 objects as local file streams to standard output. (issue 903)
feature:aws emr create-cluster: Add support for --emrfs.
feature:aws emr create-cluster: Add support for --emrfs.
feature:aws iam: Update aws iam command to latest version.
feature:aws iam: Update aws iam command to latest version.
feature:aws cognito-sync: Update aws cognito-sync command to latest version.
feature:aws opsworks: Update aws opsworks command to latest version.
feature:aws elasticbeanstalk: Add support for bundling logs.
feature:aws kinesis: Add suport for tagging.
feature:Page Size: Add a --page-size option, that controls page size when perfoming an operation that uses pagination. (issue 889)
bugfix:aws s3: Added support for ignoring and warning about files that do not exist, user does not have read permissions, or are special files (i.e. sockets, FIFOs, character special devices, and block special devices) (issue 881)
feature:Parameter Shorthand: Added support for structure(list-scalar, scalar) parameter shorthand. (issue 882)
bugfix:aws s3: Fix bug when unknown options were passed to aws s3 commands (issue 886)
bugfix:Endpoint URL: Provide a better error message when an invalid --endpoint-url is provided (issue 899)
bugfix:aws s3: Fix issue when keys do not get properly url decoded when syncing from a bucket that requires pagination to a bucket that requires less pagination (issue 909)
feature:aws cloudsearchdomain: Added sigv4 support.
feature:aws cloudsearchdomain: Added sigv4 support.
bugfix:Credentials: Raise an error if an incomplete profile is found (issue 690)
feature:Signing Requests: Add a --no-sign-request option that, when specified, will not sign any requests.
bugfix:aws s3: Added -source-region argument to allow transfer between non DNS compatible buckets that were located in different regions. (issue 872)
feature:aws elb: Add support for AWS Elastic Load Balancing tagging
feature:aws elb: Add support for AWS Elastic Load Balancing tagging
feature:aws emr: Move emr out of preview mode.
feature:aws emr: Move emr out of preview mode.
bugfix:aws s3api: Fix serialization of several s3 api commands. (issue botocore 193)
bugfix:aws s3 sync: Fix issue for unnecessarily resyncing files on windows machines. (issue 843)
bugfix:aws s3 sync: Fix issue where keys were being decoded twice when syncing between buckets. (issue 862)
bugfix:aws ec2 describe-network-interface-attribute: Fix issue where the model for the aws ec2 describe-network-interface-attribute was incorrect (iss
bugfix:aws ec2 describe-network-interface-attribute: Fix issue where the model for the aws ec2 describe-network-interface-attribute was incorrect (issue 558)
bugfix:aws s3: Add option to not follow symlinks via --[no]-follow-symlinks. Note that the default behavior of following symlinks is left unchanged. (issue 854, issue 453, issue 781)
bugfix:aws route53 change-tags-for-resource: Fix serialization issue for aws route53 change-tags-for-resource (botocore issue 328)
bugfix:aws ec2 describe-network-interface-attribute: Update parameters to add the --attribute argument (botocore issue 327)
feature:aws autoscaling: Update command to the latest version
feature:aws elasticache: Update command to the latest version
feature:aws route53: Update command to the latest version
feature:aws route53domains: Add support for Amazon Route53 Domains
bugfix:aws s3/s3api: Fix issue where Deprecations were being written to stderr in Python 3.4.1 issue botocore 319 __)
feature:aws elasticloadbalancing: Update to the latest service model.
bugfix:aws swf poll-for-decision-task: Fix issue where the default paginated response is missing output response keys (issue botocore 324)
bugfix:Connections: Fix issue where connections were hanging when network issues occurred issue botocore 325)
bugfix:aws s3/s3api: Fix issue where Deprecations were being written to stderr in Python 3.4.1 issue botocore 319)
feature:aws support: Update aws support command to the latest version
feature:aws support: Update aws support command to the latest version
feature:aws iam: Update aws iam command to the latest version
feature:aws emr: Add --hive-site option to aws emr create-cluster and aws emr install-application commands
feature:aws s3 sync: Add an --exact-timestamps option to the aws s3 sync command (issue 824)
bugfix:aws ec2 copy-snapshot: Fix bug when spaces in the description caused the copy request to fail (issue botocore 321)
feature:aws cwlogs: Add support for Amazon CloudWatch Logs
feature:aws cwlogs: Add support for Amazon CloudWatch Logs
feature:aws cognito-sync: Add support for Amazon Cognito Service
feature:aws cognito-identity: Add support for Amazon Cognito Identity Service
feature:aws route53: Update aws route53 command to the latest version
feature:aws ec2: Update aws ec2 command to the latest version
bugfix:aws s3/s3api: Fix issue where --endpoint-url wasn't being used for aws s3/s3api commands (issue 549)
bugfix:aws s3 mv: Fix bug where using the aws s3 mv command to move a large file onto itself results in the file being deleted (issue 831)
bugfix:aws s3: Fix issue where parts in a multipart upload are stil being uploaded when a part has failed (issue 834)
bugfix:Windows: Fix issue where python.exe is on a path that contains spaces (issue 825)
feature:aws opsworks: Update the aws opsworks command to the latest version
feature:aws opsworks: Update the aws opsworks command to the latest version
bugfix:Shorthand JSON: Fix bug where shorthand lists with a single item (e.g. --arg Param=[item]) were not parsed correctly. (issue 830)
bugfix:Text output: Fix bug when rendering only scalars that are numbers in text output (issue 829)
bugfix:aws cloudsearchdomain: Fix bug where --endpoint-url is required even for help subcommands (issue 828)
feature:aws cloudsearchdomain: Add support for the Amazon CloudSearch Domain command.
feature:aws cloudsearchdomain: Add support for the Amazon CloudSearch Domain command.
feature:aws cloudfront: Update the Amazon CloudFront command to the latest version
feature:aws ses: Add support for delivery notifications
feature:aws ses: Add support for delivery notifications
bugfix:Region Config: Fix issue for cn-north-1 region (issue botocore 314)
bugfix:Amazon EC2 Credential File: Fix regression for parsing EC2 credential file (issue botocore 315)
bugfix:Signature Version 2: Fix timestamp format when calculating signature version 2 signatures (issue botocore 308)
feature:aws configure: Add support for setting nested attributes (issue 817 __)
feature:aws configure: Add support for setting nested attributes (issue 817)
bugfix:aws s3: Fix issue when uploading large files to newly created buckets in a non-standard region (issue 634)
feature:aws dynamodb: Add support for a local region for dynamodb (aws dynamodb --region local ...) (issue 608)
feature:aws elasticbeanstalk: Update aws elasticbeanstalk model to the latest version
feature:Documentation Examples: Add more documentatoin examples for many AWS CLI commands
feature:aws emr: Update model to the latest version
feature:``aws elastictranscoder: `` Update model to the latest version
feature:aws s3api: Add support for server-side encryption with a customer-supplied encryption key.
feature:aws s3api: Add support for server-side encryption with a customer-supplied encryption key.
feature:aws sns: Support for message attributes.
feature:aws redshift: Support for renaming clusters.
bugfix:aws s3: Fix bug related to retrying requests when 500 status codes are received (issue botocore 302 __)
bugfix:aws s3: Fix bug related to retrying requests when 500 status codes are received (issue botocore 302)
bugfix:aws s3: Fix when when using S3 in the cn-north-1 region (issue botocore 301)
bugfix:aws kinesis: Fix pagination bug when using the get-records operation (issue botocore 304)
bugfix:Python 3.4.1: Add support for python 3.4.1 (issue 800 __)
bugfix:Python 3.4.1: Add support for python 3.4.1 (issue 800)
feature:aws emr: Update preview commands for Amazon Elastic MapReduce
bugfix:aws s3: Add filename to error message when we're unable to stat local filename (issue 795 __)
bugfix:aws s3: Add filename to error message when we're unable to stat local filename (issue 795)
bugfix:aws s3api get-bucket-policy: Fix response parsing for the aws s3api get-bucket-policy command (issue 678)
bugfix:Shared Credentials: Fix bug when specifying profiles that don't exist in the CLI config file (issue botocore 294)
bugfix:aws s3: Handle Amazon S3 error responses that have a 200 OK status code (issue botocore 298)
feature:aws sts: Update the aws sts command to the latest version
feature:aws cloudsearch: Update the aws cloudsearch command to the latest version
feature:Shorthand: Add support for surrounding list parameters with [] chars in shorthand syntax (issue 788 __)
feature:Shorthand: Add support for surrounding list parameters with [] chars in shorthand syntax (issue 788)
feature:Shared credential file: Add support for the ~/.aws/credentials file
feature:aws ec2: Add support for Amazon EBS encryption
bugfix:aws s3: Fix issue when --delete and --exclude filters are used together (issue 778 __)
bugfix:aws s3: Fix issue when --delete and --exclude filters are used together (issue 778)
feature:aws route53: Update aws route53 to the latest model
bugfix:aws emr: Fix issue with aws emr retry logic not being applied correctly (botocore issue 285)
feature:aws cloudtrail: Add support for eu-west-1, ap-southeast-2, and eu-west-1 regions
feature:aws cloudtrail: Add support for eu-west-1, ap-southeast-2, and eu-west-1 regions
bugfix:aws ec2: Fix issue when specifying user data from a file containing non-ascii characters (issue 765)
bugfix:aws cloudtrail: Fix a bug with python3 when creating a subscription (issue 773)
bugfix:Shorthand: Fix issue where certain shorthand parameters were not parsing to the correct types (issue 776)
bugfix:aws cloudformation: Fix issue with parameter casing for the NotificationARNs parameter (botocore issue 283)
feature:aws cloudformation: Add support for updated API
feature:aws cloudformation: Add support for updated API
feature:aws sqs: Add support for message attributes
feature:aws sqs: Add support for message attributes
bugfix:aws s3api: Fix issue when setting metadata on an S3 object (issue 356)
feature:aws autoscaling: Add support for launching Dedicated Instances in Amazon Virtual Private Cloud
feature:aws autoscaling: Add support for launching Dedicated Instances in Amazon Virtual Private Cloud
feature:aws elasticache: Add support to backup and restore for Redis clusters
feature:aws dynamodb: Update aws dynamodb command to the latest API
bugfix:Output Format: Fix issue with encoding errors when using text and table output and redirecting to a pipe or file (issue 742 __)
bugfix:Output Format: Fix issue with encoding errors when using text and table output and redirecting to a pipe or file (issue 742)
bugfix:aws s3: Fix issue with sync re-uploading certain files (issue 749)
bugfix:Text Output: Fix issue with inconsistent text output based on order (issue 751)
bugfix:aws datapipeline: Fix issue for aggregating keys into a list when calling aws datapipeline get-pipeline-definition (issue 750)
bugfix:aws s3: Fix issue when running out of disk space during aws s3 transfers (issue 739)
feature:aws s3 sync: Add --size-only param to the aws s3 sync command (issue 472, issue 719)
bugfix:aws cloudtrail: Fix issue when using create-subscription command (issue botocore 268 __)
bugfix:aws cloudtrail: Fix issue when using create-subscription command (issue botocore 268)
feature:aws cloudsearch: Amazon CloudSearch has moved out of preview (issue 730)
bugfix:aws s3 website: Fix issue where --error-document was being ignored in certain cases (issue 714)
feature:aws opsworks: Update aws opsworks model to the latest version
feature:aws opsworks: Update aws opsworks model to the latest version
bugfix:Pagination: Fix issue with --max-items with aws route53, aws iam, and aws ses (issue 729)
bugfix:aws s3: Fix issue with fips-us-gov-west-1 endpoint (issue botocore 265)
bugfix:Table Output: Fix issue when displaying unicode characters in table output (issue 721)
bugfix:aws s3: Fix regression when syncing files with whitespace (issue 706, issue 718)
bugfix:aws ec2: Fix issue with EC2 model resulting in responses not being parsed.
bugfix:aws ec2: Fix issue with EC2 model resulting in responses not being parsed.
feature:aws ec2: Add support for Amazon VPC peering
feature:aws ec2: Add support for Amazon VPC peering
feature:aws redshift: Add support for the latest Amazon Redshift API
feature:aws cloudsearch: Add support for the latest Amazon CloudSearch API
bugfix:aws cloudformation: Documentation updates
bugfix:Argument Parsing: Fix issue when list arguments were not being decoded to unicode properly (issue 711)
bugfix:Output: Fix issue when invalid output type was provided in a config file or environment variable (issue 600)
bugfix:aws datapipeline: Fix issue when serializing pipeline definitions containing list elements (issue 705 __)
bugfix:Parameters: Fix issue parsing with CLI parameters of type long (issue 693 __)
bugfix:Parameters: Fix issue parsing with CLI parameters of type long (issue 693)
bugfix:Pagination: Fix issue where --max-items in pagination was always assumed to be an integer (issue 689)
feature:aws elb: Add support for AccessLog
bugfix:Bundled Installer: Allow creation of bundled installer with pip 1.5 (issue 691)
bugfix:aws s3: Fix issue when copying objects using aws s3 cp with key names containing + characters (issue #614)
bugfix:ec2 create-snapshot: Remove Tags key from output response (issue 247)
bugfix:aws s3: aws s3 commands should not be requiring regions (issue 681)
bugfix:CLI Arguments: Fix issue where unicode command line arguments were not being handled correctly (issue 679)
bugfix:aws s3: Fix issue where S3 downloads would hang in certain cases and could not be interrupted (issue 650 __, issue 657 __)
bugfix:aws s3: Fix issue where S3 downloads would hang in certain cases and could not be interrupted (issue 650, issue 657)
bugfix:aws s3: Support missing canned ACLs when using the --acl parameter (issue 663)
bugfix:aws rds describe-engine-default-parameters: Fix pagination issue when calling aws rds describe-engine-default-parameters (issue 607)
bugfix:aws cloudtrail: Merge existing SNS topic policy with the existing AWS CloudTrail policy instead of overwriting the default topic policy
bugfix:aws s3: Fix issue where streams were not being rewound when encountering 307 redirects with multipart uploads (issue 544)
bugfix:aws elb: Fix issue with documentation errors in aws elb help (issue 622)
bugfix:JSON Parameters: Add a more clear error message when parsing invalid JSON parameters (issue 639)
bugfix:aws s3api: Properly handle null inputs (issue 637)
bugfix:Argument Parsing: Handle files containing JSON with leading and trailing spaces (issue 640)
feature:aws route53: Update aws route53 command to support string-match health checks and the UPSERT action for the aws route53 change-resource-record
feature:aws route53: Update aws route53 command to support string-match health checks and the UPSERT action for the aws route53 change-resource-record-sets command
bugfix:Command Completion: Don't show tracebacks on SIGINT (issue 628)
bugfix:Docs: Don't duplicate enum values in reference docs (issue 632)
bugfix:aws s3: Don't require ``s3 (issue 626)
feature:aws configure: Add support for configure get and configure set command which allow you to set and get configuration values from the AWS config
feature:aws configure: Add support for configure get and configure set command which allow you to set and get configuration values from the AWS config file (`issue 602 <https://github.com/aws/aws-cli/issues/602`__)
bugfix:aws s3: Fix issue with Amazon S3 downloads on certain OSes (`issue 619 <https://github.com/aws/aws-cli/issues/619`__)
feature:aws s3: Add support for the --recursive option in the aws s3 ls command (issue 465 <https://github.com/aws/aws-cli/issues/465)
feature:aws s3: Add support for the --recursive option in the aws s3 ls command (issue 465 <https://github.com/aws/aws-cli/issues/465)
feature:Config: Add support for the AWS_CA_BUNDLE environment variable so that users can specify an alternate path to a cert bundle (issue 586)
feature:Configuration: Add metadata_service_timeout and metadata_service_num_attempts config parameters to control behavior when retrieving credentials using an IAM role (issue 597)
bugfix:aws s3: Retry intermittent aws s3 download failures including socket timeouts and content length mismatches (issue 594)
bugfix:aws s3api: Fix response parsing of aws s3api get-bucket-location (issue 345)
bugfix:aws elastictranscoder: Fix response parsing of the aws elastictranscoder command (issue 207)
feature:aws elasticache: Update aws elasticache command to not require certain parameters
feature:aws autoscaling: Add support for creating launch configuration or Auto Scaling groups using an Amazon EC2 instance, for attaching Amazon EC2 i
feature:aws autoscaling: Add support for creating launch configuration or Auto Scaling groups using an Amazon EC2 instance, for attaching Amazon EC2 isntances to an existing Auto Scaling group, and for describing the limits on the Auto Scaling resources in the aws autoscaling command
feature:Documentation: Update documentation in the aws support command
bugfix:aws ec2: Allow the --protocol customization for CreateNetworkAclEntry to also work for ReplaceNetworkAclEntry (issue 559)
bugfix:aws s3: Remove one second delay when tasks are finished running for several aws s3 subcommands (issue 551)
bugfix:Documentation: Fix bug in shorthand documentation generation that prevented certain nested structure parameters from being fully documented (issue 579)
bugfix:Config: Update default timeout from .1 second to 1 second (`botocore issue 202 <https
bugfix:aws rds: Removed filter parameter in RDS operations (`issue 515 <https
bugfix:Endpoints: Fixed region endpoint for the aws kinesis command (`botocore issue 194 <https
bugfix:aws s3: Fix issue 548 where --include/--exclude arguments for various aws s3 commands were prepending the CWD instead of the source directory f
bugfix:aws s3: Fix issue 548 where --include/--exclude arguments for various aws s3 commands were prepending the CWD instead of the source directory for filter patterns
bugfix:aws s3: Fix issue 552 where a remote location without a trailing slash would show a malformed XML error when using various aws s3 commands
feature:aws emr: Add support for tagging in aws emr command
feature:aws cloudfront: Add support for georestrictions in aws cloudfront command
feature:aws elastictranscoder: Add support for new audio compression codecs in the aws elastictranscoder command
feature:aws cloudtrail: Update the aws cloudtrail command to the latest API
feature:Endpoints: Add support for the new China (Beijing) Region. Note now includes support for the newly announced China (Beijing) Region, the service endpoints will not be accessible until the Region’s limited preview is launched in early 2014. To find out more about the new Region and request a limited preview account, please visit http://www.amazonaws.cn/.
feature:aws s3: Add support for parallel multipart uploads when copying objects between Amazon S3 locations when using the aws s3 command (issue 538)
feature:aws s3: Add support for parallel multipart uploads when copying objects between Amazon S3 locations when using the aws s3 command (issue 538)
bugfix:aws cloudformation: Fix issue 542 where the ---stack-policy-url will parameter will not interpret its value as a URL when using the aws cloudformation create-stack command
feature:aws dynamodb: Add support for global secondary indexes in the aws dynamodb command
feature:aws kinesis: Add support for the aws kinesis command
feature:aws elasticbeanstalk: Add support for worker roles in the aws elasticbeanstalk command
feature:aws emr: Add support for resource tagging and other new operations in the aws emr command
feature:aws opsworks: Add support for resource-based permissions in the aws opsworks command
feature:aws elasticache: Update the aws elasticache command to signature version 4
bugfix:aws ec2: Allow tcp, udp, icmp, all for --protocol param of the ec2 create-network-acl-entry command (issue 508 __)
bugfix:aws ec2: Allow tcp, udp, icmp, all for --protocol param of the ec2 create-network-acl-entry command (issue 508)
bugfix:aws s3: Fix bug when filtering s3 ``--include/--exclude params (issue 531)
bugfix:aws sns: Fix an issue with map type parameters raising uncaught exceptions in commands such as sns create-platform-application (issue 407)
bugfix:aws ec2: Fix an issue when both --private-ip-address and --associate-public-ip-address are specified in the ec2 run-instances command (issue 520)
bugfix:Output: Fix an issue where --output text was not providing a starting identifier for certain rows (issue 516)
feature:aws support: Update the support command to the latest version
feature:Output: Update the --query syntax to support flattening sublists (boto/jmespath#20)
bugfix:Endpoints: Allow --endpoint-url to work with the aws s3 command (issue 469 __)
bugfix:Endpoints: Allow --endpoint-url to work with the aws s3 command (issue 469)
bugfix:aws cloudtrail: Fix issue with aws cloudtrail [create|update]-subscription not honoring the --profile argument (issue 494)
bugfix:aws ec2: Fix issue with --associate-public-ip-address when a --subnet-id is provided (issue 501)
bugfix:Argument Parsing: Don't require key names for structures of single scalar values (issue 484)
bugfix:aws s3: Fix issue with symlinks silently failing during s3 sync/cp (issue 425 and issue 487)
feature:Configuration: Add a aws configure list command to show where the configuration values are sourced from (issue 513)
feature:aws cloudwatch: Update cloudwatch command to use Signature Version 4
feature:aws ec2: Update ec2 command to support enhanced network capabilities and pagination controls for describe-instances and describe-tags
feature:aws rds: Add support in rds command for copying DB snapshots from one AWS region to another
feature:aws cloudtrail: Add support for AWS Cloudtrail
feature:aws cloudtrail: Add support for AWS Cloudtrail
feature:aws iam: Add support for identity federation using SAML 2.0 in the aws iam command
feature:aws redshift: Update the aws redshift command to include several new features related to event notifications, encryption, audit logging, data load from external hosts, WLM configuration, and database distribution styles and functions
feature:aws ec2: Add a --associate-public-ip-address option to the ec2 run-instances command (issue 479)
bugfix:aws s3: Add an s3 website command for configuring website configuration for an S3 bucket (issue 482)
Your coding agent can read these notes before it upgrades. Set up the MCP server →