NewYour coding agent can read the release notes before it upgrades.Set up the MCP server →
PyPI · #3436 most downloaded on PyPI
Cloud Custodian - Policy Rules Engine
Last release 3 days ago
01 Oct 2026
Ships on a steady schedule
a new release about every 2 months
Rarely documented
notes for 2 of the last 60 stable releases
Nothing withdrawn
no release was ever pulled
10 years old
155 releases · first in 2016
policies can now be region specific (for global resources support) and support a max-resources attribute as a safety measure.
Features
Many thanks to the contributors to this release (@ewbankkit, @gwh59, @jimmyraywv, @mandeepbal, @timothystone)
Nothing published for this version
One column per quarter.
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Cloud Watch Metric filters for all supported resources (great for finding unused resources)
Features
Nothing published for this version
Nothing published for this version
Nothing published for this version
New Resources (lambda, api gateway, kinesis, log groups, firehose)
Features
Bug fixes
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
Nothing published for this version
refactor internal query model to use skew
Nothing published for this version
s3 large file support via multpart copy
Nothing published for this version
Nothing published for this version
s3 bucket policy remove-statements action
remove-statements actionattach-encrypt realtime encryptionnew asg filters for image-age and launch-config
pypy support (30% perf improve on s3 full scans)
Created Snapshot class for creating EC2 snapshots
cleanup formatting on s3stat, use a cache of conns to CW, handle permission errors on buckets
NotImplementedError on ImageAge because the date_attribute property wasn't defined in the filter. Setting date_attribute = 'CreationDate' resolved the error.Nothing published for this version
Nothing published for this version
Your coding agent can read these notes before it upgrades. Set up the MCP server →