NewYour coding agent can read the release notes before it upgrades.Set up the MCP server →
PyPI · #3192 most downloaded on PyPI
Python GSSAPI Wrapper
Last release 1 months ago
26 Aug 2026
Release timing varies
gaps range from 3 weeks to 1.1 years
Nearly every release is documented
notes for 29 of 30 stable releases
3 versions withdrawn
withdrawn after publishing
12 years old
37 releases · first in 2014
Build and test CPython 3.15 by @jborean93 in #375
Cython == 3.3.0Full Changelog: v1.11.1...v1.12.0
Full Changelog: v1.11.1...v1.12.0
Add Free-Threading and Limited API/Stable ABI by @jborean93 in #370
Full Changelog: v1.11.0...v1.11.1
One column per quarter.
Add long_description_content_type to setup by @jborean93 in #364
setup.py as required by PEP-639 by @abompard in #365Full Changelog: v1.10.0...v1.10.1
remove deprecated license classifier by @theavey in #362
Full Changelog: v1.9.0...v1.10.0
Signed-off-by: Jordan Borean <jborean93@gmail.com>
Bump Python 3.13 test version
Signed-off-by: Jordan Borean <jborean93@gmail.com>
Added Python 3.12 wheel - https://github.com/pythongssapi/python-gssapi/pull/322
Added Python 3.11 wheel - https://github.com/pythongssapi/python-gssapi/pull/303
Bumped minimum Python version to Python 3.7 - https://github.com/pythongssapi/python-gssapi/issues/299
Fix up sha512sum file generation in the GitHub release asset
Fix distutil deprecation on Python 3.10 by using setuptools instead
Nothing published for this version
Support for running tests against Heimdal in CI
Support for 32-bit Windows python (#248, #249)
Note that due to issues with our release tooling for 32-bit Windows, there effectively was no v1.6.13 release.
Nothing published for this version
Nothing published for this version
Nothing published for this version
Fix GSSAPI detection for macOS Big Sur (#235, #236)
Fix build on FreeBSD (#232, #228)
Provide python 3.9 Windows wheels (#226, #227)
There were no releases between 1.6.5 and 1.6.9 due to release pipeline issues with Github Actions; please use this release instead.
There were no releases between 1.6.5 and 1.6.9 due to release pipeline issues with Github Actions; please use this release instead.
Nothing published for this version
Nothing published for this version
Fix python_requires so that python-3.5 users hopefully don't get a version they can't use (#199, #198)
Provide wheels for python-3.8 on Windows
Windows support, with wheels! (#177, #32, others)
n.b. Due to difficulties enabling Windows support, there is no official 1.6.0 release. Please use this release instead.
Nothing published for this version
Remove warning about collections.abc usage for Python 3.7+
Added build support for mingw32
gss_set_cred_option() and gss_set_sec_context_option() (#151, #51)GSS_NO_OID_SET when creating sets (#148)Support most of the GGF Extensions
N.B.: Due to a tooling failure, there is no official 1.4.0. Please use this release instead.
Support RFC 5587: Extended GSS Mechanism Inquiry APIs
Support RFC 5587: Extended GSS Mechanism Inquiry APIs (#121)
Support RFC 5801: Using GSSAPI Mechanisms in SASL (#124)
Fix potential infinite recursion in GSSError#display_status when there is an error displaying the error (#112)
Read the linker path during setup to support properly building with Heimdal on Debian (#122)
Fix OID inequality comparison (previously would return the results of an equality comparison for inequality) (#125)
k5test and gssapi_console (#102)Correct the capitalization of the HTTP service in the tutorial to match historical convention and case sensitivity rules from RFC 4120 (#107)
Correct a link error in when referring to multiple MechTypes (#115)
Make docs work with newer versions of Sphinx (#115)
The documentation now officially lives at https://pythongssapi.github.io/python-gssapi/latest for the documentation for HEAD, and https://pythongssapi.github.io/python-gssapi/stable for the most recently-released tag
NB: this was erroneously released as v1.2.4, despite adding new features. v1.2.4 has been hidden. Please use this release instead.
Nothing published for this version
SecurityContext#delegated_creds should not be set when the low-level API returns None for delegated_creds (#96, #99)
SecurityContext#delegated_creds should not be set when the low-level API returns None for delegated_creds (#96, #99)SecurityContext#delegated_creds as a read-only property (#95, #99)Don't require enum34 in python >= 3.4
Avoid NULL dereference of "actual_mech_type"
Always use custom-specified libraries when building
New, improved, and more usable -- #64
Changelog items may be marked _LL_ or _HL_ to denote that they affect the low-level (gssapi.raw) or high-level (gssapi) APIs, respectively.
Changelog items may be marked LL or HL to denote that they affect the low-level (gssapi.raw) or high-level (gssapi) APIs, respectively.
add_cred_with_password and acquire_cred_with_password
(accessible with the password='pass' argument to the Credentials constructor
and Credentials.acquire) -- #5xyz(None) would be a valid call, allow xyz() to mean the same thing -- #29add_cred (instead of returning a new set) -- #18GSSError, when such information is available -- #11verify_mic documentationThe first version. Implements all of RFC 2744, as well as RFC 5588, the credentials import-export extension, the credentials store extension, and the
The first version. Implements all of RFC 2744, as well as RFC 5588, the credentials import-export extension, the credentials store extension, and the Service4User extension.
Your coding agent can read these notes before it upgrades. Set up the MCP server →