NewYour coding agent can read the release notes before it upgrades.Set up the MCP server →
PyPI · #84 most downloaded on PyPI
A collection of ASN.1-based protocols modules
Last release 2 years ago
no release in 18 months
Ships unpredictably
gaps range from 4 weeks to 3.3 years
Nearly every release is documented
notes for 26 of 26 stable releases
Nothing withdrawn
no release was ever pulled
16 years old
27 releases · first in 2011
Updated dependency constraint to be compatible with pyasn1 0.6.1
It's a minor release.
All changes are noted in the CHANGELOG.
All changes are noted in the CHANGELOG .
One column per quarter.
It's a major release where we drop Python 2 support entirely. The most significant changes are:
It's a major release where we drop Python 2 support entirely.
The most significant changes are:
A full list of changes can be seen in the CHANGELOG.
This major release brings many CI changes and features. Some of them are:
This major release brings many CI changes and features. Some of them are:
unittest providedA full list of changes could be seen in the CHANGELOG.
setup.cfg,
pyproject.toml, build, and
GitHub Actions.pyasn1 and pyasn1-module has been
transfered to Christian Heimes and Simon Pichugin in
PyPI support ticket #2090.pyasn1 and pyasn1-modules are now
in the GitHub organization https://github.com/pyasn1/.unittest
providedImprove test routines for modules that use certificate extensions
Added maps for use with openType to RFC 3565
rfc4210.RevRepContent data structure layoutAdded RFC3560 providing RSAES-OAEP Key Transport Algorithm in CMS
ValueSizeConstraint erroneously applied to SequenceOf
and SetOf objects via subtypeConstraint attribute to be applied
via sizeSpec attribute. Although sizeSpec takes the same constraint
objects as subtypeConstraint, the former is only verified on
de/serialization i.e. when the [constructed] object at hand is fully
populated, while the latter is applied to [scalar] types at the moment
of instantiation.Register missing test units
Register missing test units
Added modules for RFC8226 implementing JWT Claim Constraints and TN Authorization List for X.509 certificate extensions
rfc5280.AlgorithmIdentifier ANY type definitionAdded modules for RFC5083 and RFC5084 (CMS)
Copyright notice extended to the year 2018
Allow ANY DEFINED BY objects expanding automatically if requested
OCSP response blob fixed in test
Typo fixed in the dependency spec
- Pinned to pyasn1 ~0.3.4
Tests refactored into proper unit tests
Fixed typo in ASN.1 definitions at rfc2315.py
Fixed SequenceOf initializer to pass now-mandatory componentType keyword argument (since pyasn1 0.3.1)
More CRL data structures added (RFC3279)
Wheel distribution format now supported
Extensions added to text files, CVS attic flushed.
Typo fix to id_kp_serverAuth object value
License updated to vanilla BSD 2-Clause to ease package use (http://opensource.org/licenses/BSD-2-Clause).
CMP structures (RFC4210), cmpdump.py tool and test case added.
X.509 CRMF structures (RFC2511) and crmfdump.py tool added
Fixes towards Py3K compatibility
Initial revision, most code carried from pyasn1 examples.
Your coding agent can read these notes before it upgrades. Set up the MCP server →